Задать вопрос
26 апреля, 18:29

Информатика (Pascal). Составить программу нахождения наименьшего общего кратного (НОК) двух чисел m и n, используя формулу n*m=НОД (n, m) * НОК (n, m).

+3
Ответы (1)
  1. 26 апреля, 22:24
    0
    Uses crt;

    var n, m, p : real;

    nod, nok : real;

    begin

    clrscr;

    write ('n=') ; readln (a) ;

    write ('j=') ; readln (b) ;

    p:=n*m;

    while nm do

    if n>m then n:=n-m

    else m:=m-a;

    nod:=n;

    nok:=p/nod;

    writeln ('НОД:', n) ;

    write ('НОК:', nok) ;

    readln;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Информатика (Pascal). Составить программу нахождения наименьшего общего кратного (НОК) двух чисел m и n, используя формулу n*m=НОД (n, m) * ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы