Задать вопрос
16 октября, 17:22

Не особо шарю в паскале. Нужна помощь. Нужно написать программу для определения какой четверти принадлежит точка. Мне не нужно решение из интернета, без комментариев и прочего. По возможности с объяснением, а то дальше не вытяну информатику

+1
Ответы (1)
  1. 16 октября, 18:20
    0
    Var x, y:integer;

    begin

    writeln ('Программа определения местонахождения точки') ;

    writeln ('Введите координаты точки') ;

    readln (x, y) ; / / вводим координаты точки

    if (x>=0) and (y>=0) then writeln ('1 четверть') ; / / точка принадлежит 1 ч. если обе координаты положительны (это из геометрии)

    if (x=0) then writeln ('2 четверть') ; / / точка принадлежит 2 ч. если х<0, а y неотрицателен (это из геометрии)

    if (x<0) and (y<0) then writeln ('3 четверть') ; / / точка принадлежит 3 ч. если обе координаты отрицательны (это из геометрии)

    if (x>=0) and (y<0) then writeln ('4 четверть') ; / / точка принадлежит 4 ч. если х неотрицателен, а y<0 (это из геометрии)

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Не особо шарю в паскале. Нужна помощь. Нужно написать программу для определения какой четверти принадлежит точка. Мне не нужно решение из ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы