Задать вопрос
13 мая, 21:26

Написать программу в Паскале, которая прибавляет к 1 число 7 до тех пор, пока полученная сумма не превысит max число, введенное с клавиатуры. После каждого действия вывести полученную сумму, если она меньше max числа

+2
Ответы (1)
  1. 13 мая, 23:58
    0
    Var max, s:integer;

    begin

    write ('max = ') ;

    readln (max) ;

    s:=1;

    while s<=max do

    begin

    write (s,' ') ;

    s:=s+7;

    end;

    writeln;

    end.

    Пример:

    max = 40

    1 8 15 22 29 36
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу в Паскале, которая прибавляет к 1 число 7 до тех пор, пока полученная сумма не превысит max число, введенное с ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы