Задать вопрос
16 марта, 08:45

Здравствуйте. Помогите сделать задачу на PascalABC, попросили сделать с помощью записей.

Составить программу, которая

вводит данные о студентах:

№ п/п, фамилию, год рождения, пол, курс, вид спорта и выводит: выводит данные только о спортсменках по курсам и

видам спорта в алфавитном порядке.

+2
Ответы (1)
  1. 16 марта, 11:19
    0
    const n=3;

    type student=record

    fam:string[20];

    year:integer;

    sex:string[1];

    kurs:integer;

    sport:string[30];

    end;

    var x:array[1 ... n] of student; i, j:integer;

    p:student;

    begin

    for i:=1 to n do

    with x[i] do begin

    writeln ('сведенья о ', i,' студенте:') ;

    writeln ('фамилия: ') ;

    read (fam) ;

    writeln ('год рождения: ') ;

    read (year) ;

    writeln ('пол (м или ж) : ') ;

    read (sex) ;

    writeln ('курс: ') ;

    read (kurs) ;

    writeln ('вид спорта: ') ;

    read (sport) ;

    end;

    for i:=1 to n-1 do

    for j:=i+1 to n do

    if x[i]. fam>x[j]. fam then begin

    p:=x[i];

    x[i]:=x[j];

    x[j]:=p;

    end;

    for i:=1 to n do begin

    with x[i] do

    if (sex='ж') then writeln ('Фамилия студентки: ', fam,' Курс: ', kurs,' Вид спорта: ', sport) ;

    end;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Здравствуйте. Помогите сделать задачу на PascalABC, попросили сделать с помощью записей. Составить программу, которая вводит данные о ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы