Задать вопрос
28 ноября, 13:17

Помогите выполнить это задание по информатике:

Составить программу на языке Паскаль для решения следующей задачи: задать одномерный массив случайным образом и найти сумму элементов с нечётными номерами.

Прошу учесть правильность написания самой программы (Чтобы можно было вставить в паскаль и не исправлять чужие ошибки. (Я ещё в своих не разбираюсь))

+1
Ответы (1)
  1. 28 ноября, 16:13
    0
    Const N = 10;

    var i, sum: integer;

    M: array[1 ... 10] of integer;

    begin

    sum : = 0;

    for i : = 1 to N do begin

    M[ i ] : = random (11) ;

    write (M[i], ' ') ;

    if (M[ i ] mod 2 0) then sum : = sum + M[ i ];

    end;

    writeln () ;

    writeln ('Сумма всех нечетных элементов: ', sum) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Помогите выполнить это задание по информатике: Составить программу на языке Паскаль для решения следующей задачи: задать одномерный массив ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы