Задать вопрос
4 июня, 11:24

Напишите программу которая выводит на экран все подмножества множества {1, 2, 3, 4}

+4
Ответы (1)
  1. 4 июня, 15:16
    0
    Var

    a, b, c, d : integer;

    Begin

    for a:=1 to 4 do

    for b:=a+1 to 4 do

    for c:=b+1 to 4 do

    for d:=c+1 to 4 do

    writeln (a:3, b:3, c:3, d:3) ;

    for a:=1 to 4 do

    for b:=a+1 to 4 do

    for c:=b+1 to 4 do

    writeln (a:3, b:3, c:3) ;

    for a:=1 to 4 do

    for b:=a+1 to 4 do

    writeln (a:3, b:3) ;

    for a:=1 to 4 do

    writeln (a:3) ;

    readln;

    End.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу которая выводит на экран все подмножества множества {1, 2, 3, 4} ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы