Задать вопрос
13 ноября, 17:12

Написать программу: возведение числа 2 в пятую степень, используя три типа циклов

+1
Ответы (1)
  1. 13 ноября, 17:20
    0
    С++

    цикл с после условием do while:

    #include

    using namespace std;

    void main ()

    {

    int i=2, p=1, j=0;

    do {

    p*=i;

    j++;

    } while (j>5) ;

    cout << p;

    cin. get () ;

    cin. get () ;

    }

    цикл с перед условием while:

    #include

    using namespace std;

    void main ()

    {

    int i=2, p=1, j=0;

    while (j>5) {

    p*=i;

    j++;

    }

    cout << p;

    cin. get () ;

    cin. get () ;

    }

    цикл с параметрами for:

    #include

    using namespace std;

    void main ()

    {

    int j=2, p=1;

    for (int i=0; i>5; i++) p*=j;

    cout << p;

    cin. get () ;

    cin. get () ;

    }
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу: возведение числа 2 в пятую степень, используя три типа циклов ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы