Задать вопрос
19 апреля, 11:19

1) используя справочник записать значение процедур delete и insert.

2) написать программу позволяющею разделить на отдельные цифры число любой длины

+3
Ответы (1)
  1. 19 апреля, 13:27
    0
    1)

    procedure Insert (source: string; var s: string; index: integer) ;

    Вставляет подстроку source в строку s с позиции index procedure Delete (var s: string; index, count: integer) ;

    Удаляет из строки s count символов с позиции index

    2)

    var s:string; i, n, code:integer;

    begin

    write ('Введите длинное число:') ;

    readln (s) ;

    for i:=1 to length (s) do

    begin

    val (s[i], n, code) ;

    if code=0 then writeln (n) ;

    end;

    end.

    Пример:

    Введите длинное число: 3456810285

    3

    4

    5

    6

    8

    1

    0

    2

    8

    5

    Если не требуется выполнять арифметических действий с цифрами, то можно так:

    var s:string; i:integer;

    begin

    write ('Введите длинное число:') ;

    readln (s) ;

    for i:=1 to length (s) do writeln (s[i]) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «1) используя справочник записать значение процедур delete и insert. 2) написать программу позволяющею разделить на отдельные цифры число ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы