Задать вопрос
2 апреля, 20:15

Составьте программу вычисления суммы S=10+12+14 ... + 50

+1
Ответы (1)
  1. 2 апреля, 20:26
    0
    Это прогрессия с шагом d=12-10=2

    1 член=10

    50 - последний член

    an=a1+d (n-1)

    50=10+2n-2

    2n=42;

    n=21 - в последовательности 21 член

    для программы используем формулу суммы арифм. прогрессии: Sn = (a1+an) * n/2;

    составляем программу:

    Program n1;

    const a1=10;

    an=50;

    n=21;

    var S: real;

    begin

    S: = (a1+an) * n/2;

    writeln (S) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составьте программу вычисления суммы S=10+12+14 ... + 50 ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы