Задать вопрос
11 октября, 09:37

Написать программу которая запросит длинны трёх сторон треугольника. Проверить возможность его сущ. и в предположенном результате найдёт и выведет на экран площадь один. Ребята! Спасайте кто может!

+5
Ответы (1)
  1. 11 октября, 13:10
    0
    Var

    a, b, c{длины сторон}, S{площадь тр.}, p{полупериметр}:double;

    begin

    writeln ('Введите стороны треугольника:') ;

    readln (a, b, c) ;

    if (a>=b+c) or (b>=a+c) or (c>=a+b) then

    writeln ('Такого треугольника не существует')

    else begin

    p: = (a+b+c) / 2;

    S:=sqrt (p * (p-a) * (p-b) * (p-c)) ; {вычисляем S тр. по формуле Герона}

    writeln ('Такой треугольник существует, его S = ', S, 'ед.') ;

    end;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу которая запросит длинны трёх сторон треугольника. Проверить возможность его сущ. и в предположенном результате найдёт и ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы