Задать вопрос
15 марта, 15:43

Даны целые числа x и y. Написать программу определения знака разности x-y. Разность вычислять нельзя. Разрешается сравнивать числа x и y с нулем, а между собой можно сравнивать только абсолютные величины чисел x и y.

+3
Ответы (1)
  1. 15 марта, 18:33
    0
    Program raznost_xy;

    var x, y:integer;

    begin

    write ('Введите число х = ') ;

    readln (x) ;

    write ('Введите число у = ') ;

    readln (y) ;

    if (x>0) and (y>0) then

    begin

    if abs (x) >abs (y) then write ('x-y > 0') ;

    if abs (x) = abs (y) then write ('x-y = 0') ;

    if abs (x)
    end;

    if (x<0) and (y<0) then

    begin

    if abs (x) >abs (y) then write ('x-y < 0') ;

    if abs (x) = abs (y) then write ('x-y = 0') ;

    if abs (x) 0') ;

    end;

    if (x=0) and (y=0) then write ('x-y = 0') ;

    if (x>0) and (y 0') ;

    if (x0) then write ('x-y < 0') ;

    if (x=0) and (y>0) then write ('x-y < 0') ;

    if (x=0) and (y 0') ;

    if (x>0) and (y=0) then write ('x-y > 0') ;

    if (x<0) and (y=0) then write ('x-y < 0') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Даны целые числа x и y. Написать программу определения знака разности x-y. Разность вычислять нельзя. Разрешается сравнивать числа x и y с ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы