Задать вопрос
4 декабря, 11:04

Составьте программу нахождения наибольшего общего делителя трёх чисел, используя следующую формулу:

НОД (A, B, C) = НОД (НОД (A, B), C).

Нужно на паскале

+4
Ответы (1)
  1. 4 декабря, 13:23
    0
    var

    a, b, c:integer;

    begin

    write ('a = ') ; readln (a) ;

    write ('b = ') ; readln (b) ;

    write ('c = ') ; readln (c) ;

    write ('НОД (', a, ', ', b, ', ', c, ') = ') ;

    while (a 0) and (b 0) do

    if a > = b then

    a : = a mod b

    else

    b : = b mod a;

    a : = a + b;

    while (c 0) and (a 0) do

    if a > = c then

    a : = a mod c

    else

    c : = c mod a;

    writeln (a + c) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составьте программу нахождения наибольшего общего делителя трёх чисел, используя следующую формулу: НОД (A, B, C) = НОД (НОД (A, B), C). ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы