Задать вопрос
12 августа, 21:13

Составьте программу определяющую могут ли три числа a, b, c является длинами сторон треугольника

+4
Ответы (1)
  1. 12 августа, 21:47
    0
    Var

    a, b, c:real;

    begin

    Write ('Введите через пробел длины трех сторон: ') ;

    Readln (a, b, c) ;

    if (a+b>c) and (a+c>b) and (b+c>a) then

    Writeln ('Можно составить треугольник')

    else

    Writeln ('Нельзя составить треугольник')

    end.

    Тестовое решение:

    Введите через пробел длины трех сторон: 2 6 9

    Нельзя составить треугольник

    Введите через пробел длины трех сторон: 3 4 5

    Можно составить треугольник
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составьте программу определяющую могут ли три числа a, b, c является длинами сторон треугольника ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы