Задать вопрос
25 ноября, 09:00

Написать задачу на языке PascalABC 3.1

На улице дома с чётными номерами находятся с левой стороны, а с нечётными - с правой. Известно количество жителей в каждом доме. Посчитайте разницу между суммарными количествами жителей левой стороны и правой.

Входные данные

Первая строка состоит из одного числа

n (1⩽n⩽1000) - количество домов на улице. Следующая строка содержит n целых чисел xi (0⩽xi⩽10000) - количество жителей в i-м доме (1⩽i⩽n).

Результат

Нужно вывести одно целое число - разницу между суммарными количествами жителей левой стороны улицы и правой.

Пример

Исходные данные

3

3 1 4

Результат

-6

Пояснение: на левой стороне 1 житель, на правой 7, разница равна 1

+3
Ответы (1)
  1. 25 ноября, 11:46
    0
    Program t;

    varn, x, i, s, k:integer;

    a:array [0 ... 20] of integer; {20 = это максимальное количество домов. Вместо 20 поставь любое число}

    begin

    write ('Введите количество домов на улице : ') ;

    read (n) ;

    for i:=1 to n do

    begin

    write ('Введите количество жителей в ', i, ' - м доме : ') ;

    read (a[i]) ;

    end;

    for i:=1 to n do

    if i mod 2=0 then s:=a[i]+s; {Считаем жителей правых}

    for i:=1 to n do

    if i mod 2=1 then k:=a[i]+k; {Считаем жителей левых}

    if s>k then write ('Разница между домами ', k-s) ;

    if s
    end.

    Введите количество домов на улице: 3

    Введите количество жителей в 1 - м доме: 3

    Введите количество жителей в 2 - м доме: 1

    Введите количество жителей в 3 - м доме: 4

    Разница между домами - 6

    Писал на Версии 3.3

    Скобки это комментарии, их можно убрать
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать задачу на языке PascalABC 3.1 На улице дома с чётными номерами находятся с левой стороны, а с нечётными - с правой. Известно ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы