Задать вопрос
6 ноября, 21:13

Помогите составить программу, вычисляющую сумму квадратов n чётных натуральных чисел

(сейчас прошли циклические алгоритмы, нужна и блок-схема)

+1
Ответы (1)
  1. 6 ноября, 23:32
    0
    Var n, a, i:integer;

    s:longint;

    begin

    writeln ('введите количество чисел') ;

    readln (n) ;

    a:=0; s:=0;

    writeln ('введите числа') ;

    for i:=1 to n do begin

    readln (a) ;

    if a>10 then s:=s+a*a;

    end;

    if s=0 then writeln ('положительных чисел нет') else writeln (s) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Помогите составить программу, вычисляющую сумму квадратов n чётных натуральных чисел (сейчас прошли циклические алгоритмы, нужна и ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы