Задать вопрос
8 мая, 08:15

Составить программу вычисления,

A - сумма положительных элементов массива;

B - номер наименьшего элемента массива;

C - количество элементов массива кратных пяти.

Полученные значения элементов А, B, C, W вывести на печать. (Паскаль)

+2
Ответы (1)
  1. 8 мая, 11:26
    0
    Program z1;

    var

    mas: array[1 ... 100] of integer;

    i, a, b, c, n, min: integer;

    begin

    a:=0;

    min:=1000;

    c:=0;

    writeln ('Введите количество элементов массива') ;

    readln (n) ;

    writeln ('Введите элементы массива') ;

    for i:=1 to n do

    begin

    read (mas[i]) ;

    if mas[i]>0 then

    a:=a+mas[i];

    if mas[i]
    begin

    min:=mas[i];

    b:=i;

    end;

    if mas[i] mod 5=0 then

    c:=c+1;

    end;

    writeln ('Сумма положительных элементов массива равна ', a) ;

    writeln ('Номер наименьшего элемента массива равен ', b) ;

    writeln ('Количество элементов массива, кратных пяти, равно ', c) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составить программу вычисления, A - сумма положительных элементов массива; B - номер наименьшего элемента массива; C - количество элементов ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы