Задать вопрос
9 мая, 18:34

Каждый солнечный день улитка сидящая на дереве поднимается на 2 см а в каждый пасмурный день опускается на 1 см. в начале ноября улитка находилась ы А см от земли на В дереве. имеется 30 элем. массив содержащим сведенья о том был ли соответствующий деньпасмурным или солнечным. написать программу определяющее место положения улитки к концу 30 дня наблюдения

+5
Ответы (1)
  1. 9 мая, 20:56
    0
    Program Ulitka;

    Var SunnyDay: Array [1 ... 30] Of Boolean;

    a, b, c, i: Integer;

    Begin

    WriteLn ('a = ') ;

    ReadLn (a) ;

    WriteLn ('b = ') ;

    ReadLn (b) ;

    b : = b * 100;

    Randomize;

    For i : = 1 To 30 Do

    Begin

    If Random (2) = 1 Then

    SunnyDay[i] : = True

    Else

    SunnyDay[i] : = False;

    End;

    For i : = 1 To 30 Do

    Begin

    If SunnyDay[i] = True Then

    Begin

    a : = a + 2;

    If a > b Then

    a : = b;

    End

    Else

    Begin

    a : = a - 1;

    If a < 0 Then

    a : = 0;

    End;

    End;

    WriteLn ('Дни месяца были таковы:') ;

    For i : = 1 To 30 Do Begin

    If SunnyDay[i] = True Then

    WriteLn (i, '. Солнечный')

    Else

    WriteLn (i, '. Пасмурный')

    End;

    WriteLn ('К концу 30 дня местоположение улитки равно ', a, ' см над землей') ;

    ReadLn;

    End.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Каждый солнечный день улитка сидящая на дереве поднимается на 2 см а в каждый пасмурный день опускается на 1 см. в начале ноября улитка ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы