Задать вопрос
5 июня, 17:44

Напишите рекурсивную функцию, возводящую число a в степень n. Гарантируется, что все числа "помещаются" в стандартные вещественные (a и ответ) и целые (n) типы.

Входные данные

Вводится 2 числа - a и n (число n может быть отрицательным).

Выходные данные

Необходимо вывести значение an

Примеры

входные данные

2 - 1

выходные данные

0.5

+4
Ответы (1)
  1. 5 июня, 19:47
    0
    Var a, f: real; n, i, g: integer; begin read (a, n) ; if n<0 then begin g:=n; n:=-n; end; f:=1; for i:=1 to n do f:=a*f; if g<0 then write (1/f) else write (f) ; readln; readln end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите рекурсивную функцию, возводящую число a в степень n. Гарантируется, что все числа "помещаются" в стандартные вещественные (a и ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы