Задать вопрос
26 сентября, 01:29

Запишите на языке Паскаль программу, которая для произвольного натурального двузначного числа

1) сумму и произведение его цифр;

2) число, образованное перестановкой цифр исходного числа.

+5
Ответы (1)
  1. 26 сентября, 02:13
    0
    Var n, sum, pr, a:integer;

    begin

    readln (n) ;

    sum:=0

    pr:=1;

    while n0 do

    begin

    a:=n mod 10;

    sum:=sum+a;

    pr:=pr*a;

    n:=n div 10;

    end;

    writeln (sum,' ', pr) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Запишите на языке Паскаль программу, которая для произвольного натурального двузначного числа 1) сумму и произведение его цифр; 2) число, ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Похожие вопросы по информатике
Домашнее задание: 1. Запишите на языке Паскаль программу, которая для произвольного двузначного числа определяет сумму и произведение его цифр. 2.
Ответы (1)
запишите на языке паскаль программу, которая для произвольного двузначного числа определяет число, образованное перестановкой цифр исходного числа.
Ответы (2)
Составьте программу, которая для произвольного натурального двузначного числа определяет число, образованное перестановкой цифр исходного числа.
Ответы (1)
Напишите на языке Паскаль программу, которая для произвольного двухзначного числа определяет число, образованное перестановкой цифр исходного числа.
Ответы (1)
Помогите решить! 1) Дано натуральное трехзначное число N. Определить сумму и произведение его цифр. 2) Дано натуральное трехзначное число N. Найдите число, образованное перестановкой цифр исходного числа в обратном порядке.
Ответы (1)