Задать вопрос
23 февраля, 22:25

Составить

программу, определяющую животное, соответствующее году по китайскому гороскопу

+1
Ответы (2)
  1. 24 февраля, 00:05
    0
    Program god_Japan;

    var y, y1: Integer;

    color : Integer;

    beast : Integer;

    begin

    Write ('Введите год') ;

    ReadLn (year) ;

    year1 : = ((year - 1984) mod 60 + 60) mod 60;

    beast : = year1 mod 12;

    color : = (year1 div 12) mod 5;

    Write (year, ' - год ') ;

    if beast in [2, 3, 4] then

    case color of

    0: Write ('зеленого') ;

    1: Write ('красного') ;

    2: Write ('желтого') ;

    3: Write ('белого') ;

    4: Write ('черного') ;

    end

    else

    case color of

    0: Write ('зеленой') ;

    1: Write ('красной') ;

    2: Write ('желтой') ;

    3: Write ('белой') ;

    4: Write ('черной') ;

    end;

    Write (' ') ;

    case beast of

    0: Write ('Крысы') ;

    1: Write ('Коровы') ;

    2: Write ('Тигра') ;

    3: Write ('Зайца') ;

    4: Write ('Дракона') ;

    5: Write ('Змеи') ;

    6: Write ('Лошади') ;

    7: Write ('Овцы') ;

    8: Write ('Обезьяны') ;

    9: Write ('Курицы') ;

    10: Write ('Собаки') ;

    11: Write ('Свиньи') ;

    end;

    WriteLn () ;

    end.
  2. 24 февраля, 01:00
    0
    var a, b, c, i:integer;

    begin

    read (a) ;

    a:=a-4;

    if a = - 3 then write ('Петух') ;

    if a = - 2 then write ('Собака') ;

    if a = - 1 then write ('Свинья ') ;

    if a mod 12 = 0 then writeln ('Крыса') ;

    if a mod 12 = 1 then writeln ('Бык') ;

    if a mod 12 = 2 then writeln ('Тигр') ;

    if a mod 12 = 3 then writeln ('Кролик') ;

    if a mod 12 = 4 then writeln ('Дракон') ;

    if a mod 12 = 5 then writeln ('Змея') ;

    if a mod 12 = 6 then writeln ('Лошадь') ;

    if a mod 12 = 7 then writeln ('Овца') ;

    if a mod 12 = 8 then writeln ('Обезьяна') ;

    if a mod 12 = 9 then writeln ('Петух') ;

    if a mod 12 = 10 then writeln ('Собака') ;

    if a mod 12 = 11 then writeln ('Свинья') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составить программу, определяющую животное, соответствующее году по китайскому гороскопу ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы