Задать вопрос
18 сентября, 02:20

1. Составить алгоритм и программу нахождения суммы следующих чисел: 1, 12, 35, 70, 117, ... 532.

2.-х-

3. Написать программу, которая вводит с клавиатуры число от 0 до 999999 (использовать переменные типа longint) и выдает на экран дисплея сумму цифр этого числа.

4. Составить алгоритм и программу сортировки массива символов латинского алфавита.

5. Составить алгоритм и программу сортировки массива по убыванию методом пузырьков с перемещнием минимального элемента.

---

хотя бы с одним помогите

+4
Ответы (1)
  1. 18 сентября, 05:02
    0
    3. pascal

    var s, a: integer;

    g:longint;

    begin

    s:=0;

    readln (g) ;

    while g > 0 do

    begin

    a:=g mod 10;

    g:=g div 10;

    s:=s+a;

    end;

    writeln (s)

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «1. Составить алгоритм и программу нахождения суммы следующих чисел: 1, 12, 35, 70, 117, ... 532. 2.-х- 3. Написать программу, которая ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы