Задать вопрос
19 июля, 00:33

1). Дан массив из n элементов (n > = 4). Подсчитать среднюю арифметическую второго и предпоследнего элемента массива.

2). Дан массив из n элементов. Написать программу подсчитывающую произведение элементов массива.

+5
Ответы (1)
  1. 19 июля, 03:54
    0
    Var a:array[1 ... 50000] of integer;

    n, i, p:integer;

    sr:real;

    begin

    readln (n) ;

    p:=1;

    for i:=1 to n do begin

    read (a[i]) ;

    p*=a[i];

    end;

    sr: = (a[2]+a[n-1]) / 2;

    writeln ('Среднее ар. - ', sr:2:1,' произведение - ', p) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «1). Дан массив из n элементов (n > = 4). Подсчитать среднюю арифметическую второго и предпоследнего элемента массива. 2). Дан массив из n ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы