Задать вопрос
21 января, 09:21

3. Написать программу, которая запрашивает ввод целого числа в переменную B и выводит это число на экран. Проверить правильность работы программы на числах 1, - 5, 256, 10455.

4. Написать программу, которая запрашивает ввод вещественного числа в переменную C, умножает это число на 2 и выводит результат на экран. Проверить правильность работы программы на числах 2.5, - 7.33, 0, 782.234.

5. Написать программу для ввода значения величины X целого типа, присваивания величине Y действительного типа значения 5.5, вычисления значения величины Z = X - Y и вывода значения величины Z. Протестировать программу для X=5.5, X=0, X=-10.2

6. Написать программу для ввода значения величины X целого типа, присваивания величине Y действительного типа значения 2.5, вычисления значения величины Z=X/Y и вывода значения величины Z. Протестировать программу для X=5, X=0, X=-8.75

+2
Ответы (1)
  1. 21 января, 10:21
    0
    3. program n3;

    uses crt;

    var b:integer;

    begin

    write ('Введите число ') ;

    read (b) ;

    writeln (b) ;

    end.

    4. program n4;

    uses crt;

    var c:real;

    begin

    write ('Введите число ') ;

    readln (c) ;

    c:=c*2;

    writeln ('Ответ равен 'c) ;

    end.

    5. program n5;

    uses crt;

    var y, z, x:real;

    begin

    write ('Введите число ') ;

    readln (x) ;

    y:=5.5;

    z:=x-y;

    writeln ('Ответ равен 'z) ;

    end.

    6. program n6;

    uses crt;

    var y, x, z:real;

    begin

    write ('Введите число ') ;

    readln (x) ;

    y:=2.5;

    z:=x/y;

    writeln ('Ответ равен 'z) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «3. Написать программу, которая запрашивает ввод целого числа в переменную B и выводит это число на экран. Проверить правильность работы ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы