Задать вопрос
14 октября, 16:03

Напишите программу на паскале)

1. С клавиатуры вводится 3-хзначное число. Определить какая из его цифр больше.

2. С клавиатуры вводится 3-хзначное число. Определить является ли произведение его цифр 3-хзначным числом.

3. С клавиатуры вводится 4-хзначное число. Определить, равна ли сумма первых двух цифр сумме последних двух.

+4
Ответы (1)
  1. 14 октября, 18:32
    0
    program pervoe;

    var a, b, c, c1, d, max:integer;

    begin

    readln (a) ;

    b:=a div 100;

    c: = a mod 10;

    c1: = a mod 100;

    d: = c1 div 10;

    if (b > c) then max: = b

    else max: = c;

    if (max < d) then max : = d; writeln (max) ;

    readln;

    end.

    2) program vtoroe;

    var a, b, c, c1, d, pro:integer;

    begin

    readln (a) ;

    b:=a div 100;

    c: = a mod 10;

    c1: = a mod 100;

    d: = c1 div 10;

    pro: = b * c * d;

    if (pro > 99) and (pro < 1000) then writeln ('Yes') ;

    readln;

    end.

    3) program trete;

    var a, b, c, d, e, f, g, j, sum1, sum2:integer;

    begin

    readln (a) ;

    b:=a div 1000; {1}

    c:=a mod 10; {4}

    e:=a mod 1000; {234}

    f:=e div 100; {2}

    g:=e mod 100; {34}

    j:=g div 10; {3}

    sum1: = b + f;

    sum2: = j + c;

    if (sum1 = sum2) then writeln ('Yes')

    else writeln ('NO') ;

    readln;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу на паскале) 1. С клавиатуры вводится 3-хзначное число. Определить какая из его цифр больше. 2. С клавиатуры вводится ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы