Задать вопрос
19 ноября, 11:37

написать программу на Pascal -

В одномерном массиве целых чисел, содержащем 20 элементов, удалить k-ый элемент массива. Массив заполняется случайным образом числами от 0 до 50.

+5
Ответы (1)
  1. 19 ноября, 14:37
    0
    const

    n = 20;

    var

    a:array[1 ... n] of integer;

    i, k:integer;

    begin

    randomize;

    writeln ('Исходный массив: ') ;

    for i : = 1 to n do

    begin

    a[i] : = random (51) ;

    write (a[i], ' ') ;

    end;

    writeln;

    write ('k = ') ; readln (k) ;

    if (k > n) or (k < 1) then

    begin

    writeln ('элемента с таким индексом нет') ;

    readln;

    Exit;

    end;

    for i : = k to n - 1 do

    a[i] : = a[i + 1];

    a[n] : = 0;

    writeln ('Измененный массив:') ;

    for i : = 1 to n - 1 do

    write (a[i], ' ') ;

    readln;

    writeln;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «написать программу на Pascal - В одномерном массиве целых чисел, содержащем 20 элементов, удалить k-ый элемент массива. Массив заполняется ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы