Задать вопрос
5 сентября, 06:01

Найти все трёхзначные цифры, такие, что сумма цифр равна А, а само число делится на В (А и В вводятся с клавиатуры).

+3
Ответы (2)
  1. 5 сентября, 06:22
    0
    var

    a, b, i, s:integer;

    readln (a) ;

    readln (b) ;

    for i=100 to 999 do

    begin

    if (i mod 10) + (i div 100) + ((i mod 100) div 10) = a then

    begin

    if i mod b = 0 then

    writeln (i) ;

    end;

    end;

    end.
  2. 5 сентября, 07:34
    0
    uses crt;

    var a, b, i, s:integer;

    begin

    clrscr;

    writeln ('введите a') ;

    readln (a) ;

    writeln ('введите b') ;

    readln (b) ;

    for i=100 to 999 do

    begin

    if (i mod 10) + (i div 100) + ((i mod 100) div 10) = a then

    begin

    if i mod b = 0 then

    writeln (i) ;

    end;

    end;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Найти все трёхзначные цифры, такие, что сумма цифр равна А, а само число делится на В (А и В вводятся с клавиатуры). ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Похожие вопросы по информатике
Задания по Pascal №1 найти все двузначные числа, такие, что сумма цифр равна A, а само число делится на B. A и B вводятся с клавиатуры. №2 найти сумму всех чисел из промежутка от A до B, кратных 5. A и B вводятся с клавиатуры.
Ответы (1)
1) Запишите внутреннее представление десятичного числа - 104 в 8-разрядной ячейке памяти компьютера Ниже запишите ответ - только само число, без пояснений 2) Запишите внутреннее представление десятичного числа 79 в 8-разрядной ячейке памяти
Ответы (1)
Помогите решить задачи! 1. Дан массив размера 10, числовые значения которого вводятся с клавиатуры. Вывести максимальный элемент данного массива и его номер. 2. Дан массив размера 10, числовые значения которого вводятся с клавиатуры.
Ответы (1)
1. Напишите программу вычисления корней квадратного уравнения, если с клавиатуры, если коэффициенты вводятся с клавиатуры (a, b, c) 2. Координаты 2-х точек плоскости вводятся с клавиатуры.
Ответы (1)
Написать программу в Паскале: 1) Вводятся 10 целых чисел. Подсчитать количество четных среди них 2) Вывести на экран все трехзначные числа, сумма цифр которых равна n (значение n вводится с клавиатуры).
Ответы (1)