Задать вопрос
30 ноября, 21:41

Дано 3-х значное число (х). Составить программу для вычесления суммы и произведения цифр числа

Program ynp2;

var x, x1, x2, x3; p: integer;

begin

Write (' введите трёхзначное число') ;

Read (x) ;

x1: x mod 100;

x3: x div 100;

+1
Ответы (1)
  1. 1 декабря, 01:18
    0
    X2: = (x div 10) mod 10;

    sum:=x1+x2+x3; (Сумма)

    mul:=x1*x2*x3; (Произведение)
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Дано 3-х значное число (х). Составить программу для вычесления суммы и произведения цифр числа Program ynp2; var x, x1, x2, x3; p: integer; ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы