Задать вопрос
5 февраля, 00:20

Написать программу, которая запрашивает массив размерности N и выводит на экран сам массив, а также наибольший и наименьший элементы массива. Протестировать программу на массивах размерностью 5 и 10 элементов.

+4
Ответы (1)
  1. 5 февраля, 00:52
    0
    Var a:array [1 ... 100] of integer;

    max, min, n, i:integer;

    begin

    readln (n) ;

    for i:=1 to n do

    read (a[i]) ;

    for i:=1 to 10 do

    write (a[i],' ') ;

    max:=-maxint;

    min:=maxint;

    for i:=1 to n do begin

    if a[i]>max then max:=a[i];

    if a[i]
    end;

    writeln ('Наибольший элемент: ', max) ;

    writeln ('Наименьший элемент: ', min)

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу, которая запрашивает массив размерности N и выводит на экран сам массив, а также наибольший и наименьший элементы ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы