Задать вопрос
15 апреля, 13:22

Написать программу в Паскале. Даны два числа. Меньшее из них замените полусуммой этих чисел, а большее - их произведением. Составить блок-схему.

+3
Ответы (1)
  1. 15 апреля, 17:17
    0
    Var a, b:integer;

    begin

    writeln ('a=') ;

    readln (a) ;

    writeln ('b=') ;

    readln (b) ;

    if (a>b) then begin

    b: = (a+b) / 2;

    a:=a*b;

    end

    else

    begin

    a: = (a+b) / 2;

    b:=a*b;

    end;

    writeln ('a=', a, ' b=', b) ;

    readln;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу в Паскале. Даны два числа. Меньшее из них замените полусуммой этих чисел, а большее - их произведением. Составить ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы