Задать вопрос
13 января, 21:22

Написать программу в Паскале:

1) Вводятся 10 целых чисел. Подсчитать количество четных среди них

2) Вывести на экран все трехзначные числа, сумма цифр которых равна n (значение n вводится с клавиатуры).

3) Вывести на экран все трехзначные числа-палиндромы, т. е. такие числа, которые одинаково читаются как слева направо, так и справа налево.

+5
Ответы (1)
  1. 13 января, 21:28
    0
    var

    i, c : byte;

    t : integer;

    begin

    c : = 0;

    for i : = 1 to 10 do

    begin

    read (t) ;

    if t mod 2 = 0 then inc (c) ;

    end;

    writeln (c) ;

    end.

    var

    n, i : integer;

    begin

    read (n) ;

    for i : = 100 to 999 do

    if i mod 10 + i div 10 mod 10 + i div 100 = n then writeln (i) ;

    end.

    var

    i : integer;

    begin

    for i : = 100 to 999 do

    if i mod 10 = i div 100 then writeln (i) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу в Паскале: 1) Вводятся 10 целых чисел. Подсчитать количество четных среди них 2) Вывести на экран все трехзначные числа, ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы