Задать вопрос
22 мая, 00:22

Написать программу решения квадратных уравнений. Вычисление D оформить процедурой (паскаль).

+2
Ответы (1)
  1. 22 мая, 01:55
    0
    Var a, b, c, d:real;

    procedure p (a, b, c:real; var d:real) ;

    begin

    d:=b*b-4*a*c;

    end;

    begin

    readln (a, b, c) ;

    p (a, b, c, d) ;

    if d<0 then writeln ('Корней нет')

    else if d=0 then writeln ('x = ',-b / (2*a) : 3:1)

    else writeln ('x1 = ', (-b+d) / (2*a) : 3:1,' x2 = ', (-b-d) / (2*a) : 3:1) ;

    end.

    Пример:

    2 3 1

    x1 = - 0.5 x2 = - 1.0
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу решения квадратных уравнений. Вычисление D оформить процедурой (паскаль). ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы