Задать вопрос
24 декабря, 02:35

Дано натуральное число.

Верно ли, что количество его цифр есть четное число, а само число не превышает b?

Написать программу на паскале используя циклы, но не используя массивы, строковый тип и boolean

+5
Ответы (1)
  1. 24 декабря, 06:00
    0
    Var i, n, k, b: integer;

    begin

    write (' b = ') ; readln (b) ;

    write (' n = ') ; readln (n) ;

    i:=n; k:=0;

    while i>0 do

    begin

    i:=i div 10; k:=k+1;

    end;

    if n<=b then writeln ('число n не превышает ', b)

    else writeln ('число n больше ', b) ;

    if (k mod 2) = 0 then writeln ('число цифр = ', k,' - четное')

    else writeln ('число цифр ', k,' - нечетное') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Дано натуральное число. Верно ли, что количество его цифр есть четное число, а само число не превышает b? Написать программу на паскале ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы