Задать вопрос
6 февраля, 14:51

Напишите программу, которая находит среди элементов массива, состоящего из n элементов, наименьший элемент и его порядковый номер.

+3
Ответы (1)
  1. 6 февраля, 15:20
    0
    Var

    a:array[1 ... 1000000]of integer;

    i, min, n, c:integer;

    begin

    readln (n) ;

    for i:=1 to n do

    begin

    read (a[i]) ;

    if i = 1 then

    min:=a[i];

    if a[i]
    begin

    min:=min+a[i];

    a[i]:=min - a[i];

    min:=min - a[i];

    c:=i;

    end;

    end;

    writeln ('a[', c,']=', min) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу, которая находит среди элементов массива, состоящего из n элементов, наименьший элемент и его порядковый номер. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы