Задать вопрос
17 декабря, 12:52

Дан массив из 30 произвольных элементов, каждый из которых не больше 100. Найдите максимальный элемент кратный 9.

+5
Ответы (1)
  1. 17 декабря, 15:44
    0
    Const

    N = 30;

    Var

    A:array[1 ... N] of byte;

    i, Max:integer;

    Begin

    Max:=0;

    For i: = 1 to N do

    Begin

    A[i]:=random (101) ;

    if (A[i] mod 9 = 0) and (A[i] > Max) then Max:=A[i];

    Write (A[i],' ') ;

    End;

    WriteLn;

    if Max = 0 then WriteLn ('В массиве нет элементов, кратных 9')

    else WriteLn ('Max = ', Max)

    End.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Дан массив из 30 произвольных элементов, каждый из которых не больше 100. Найдите максимальный элемент кратный 9. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы