Задать вопрос
24 февраля, 08:09

Напишите программу, которая определяет количество различных символов, встречающихся в символьной строке.

Входные данные

На вход программы подаётся символьная строка.

Выходные данные

Программа должна вывести количество различных символов в этой строке.

Примеры

входные данные

aB122AB

выходные данные

5

Pascal ABC 1.8

+1
Ответы (1)
  1. 24 февраля, 09:15
    0
    Var used: Set of Char;

    s: string;

    i, cnt: integer;

    c: char;

    begin

    used : = [];

    readln (s) ;

    for i : = 1 to length (s) do

    include (used, s[i]) ;

    cnt : = 0;

    for c : = #0 to #255 do

    if (c in used) then

    cnt : = cnt + 1;

    writeln (cnt) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу, которая определяет количество различных символов, встречающихся в символьной строке. Входные данные На вход программы ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы