Задать вопрос
26 июля, 02:31

Найти все натуральные числа, не превосходящие заданного N и равные сумме кубов его цифр.

var i, j, k : byte;

begin

for i:=1 to 9 do

for j:=0 to 9 do

for k:=0 to 9 do

if i*i*i + j*j*j + k*k*k = i*100+j*10+k then writeln (i, j, k) ;

readln;

end.

Как сделать ввод самих значений, чтобы программа соответствовала заданию?

var i, j, k, n: integer;

begin

write ('Введите значение n=') ;

readln (n) ;

begin

for i:=1 to n do

for j:=0 to n do

for k:=0 to n do

if i*i*i + j*j*j + k*k*k = i*100+j*10+k then writeln (i, j, k) ;

readln;

end;

end.

Или как правильнее написать программу?

+2
Ответы (1)
  1. 26 июля, 05:51
    0
    Var

    n, s, i, j: integer;

    begin

    read (n) ;

    for i : = 1 to n. ToString. Length do

    s : = s + round (power (strtoint (n. ToString[i]), 3)) ;

    for i : = 1 to n do if (i = s) then writeln (i) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Найти все натуральные числа, не превосходящие заданного N и равные сумме кубов его цифр. var i, j, k : byte; begin for i:=1 to 9 do for ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы