Задать вопрос
30 января, 13:33

Надо написать программу на Паскале, без массивов.

Дано натуральное число. Определить, сколько раз у этого числа встречается минимальная цифра. (Например, при вводе числа 2618319, на экране должно быть "2").

+2
Ответы (2)
  1. 30 января, 15:47
    0
    Var

    s:string;

    c:char;

    i, k:integer;

    begin

    Write ('Введите число: ') ; Readln (s) ;

    c:=s[1]; k:=1;

    for i:=2 to length (s) do

    if s[i]=c then Inc (k)

    else if s[i]
    Writeln ('Наименьшая цифра ', c,' встретилась ', k,' раз (а) ')

    end.

    Тестовое решение:

    Введите число: 3141592653589793

    Наименьшая цифра 1 встретилась 2 раз (а)
  2. 30 января, 17:26
    0
    Var a, k, count: integer;

    begin

    readln (a) ;

    k:=a mod 10;

    a:=a div 10;

    count:=1;

    while (a0) do begin

    if (a mod 10 = k) then count+=1;

    if (a mod 10 < k) then begin

    k:=a mod 10;

    count:=1;

    end;

    a:=a div 10;

    end;

    writeln (count) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Надо написать программу на Паскале, без массивов. Дано натуральное число. Определить, сколько раз у этого числа встречается минимальная ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы