Задать вопрос
20 августа, 09:38

Нужно составить программу в paskal ABC:

Массив содержит n случайных двузначных чисел. Определить сколько в данном массиве четных чисел. Вывести все его элементы с нечетными номерами.

+1
Ответы (2)
  1. 20 августа, 10:56
    0
    Var a: array [1 ... 10] of integer; var kolvo:integer; beginfor var i: = 1 to 10 do a[i]: = random (89) + 10; for var c: = 1 to 10 do begin if (a[c] mod 2 = 0) then kolvo:=kolvo+1; end; writeln ('Четных чисел: ', kolvo) ; for var i: = 1 to 10 do write (a[i]:4) ; end. объяснение нужно?
  2. 20 августа, 12:12
    0
    Const n=10;

    var a:array[1 ... n] of integer;

    i, k:integer;

    begin

    Randomize;

    writeln ('Массив A:') ;

    for i:=1 to n do

    begin

    a[i]:=random (90) + 10;

    write (a[i]:4) ;

    end;

    writeln;

    k:=0;

    for i:=1 to n do

    if a[i] mod 2=0 then k:=k+1;

    writeln ('Четных чисел: ', k) ;

    writeln ('Элементы с нечетными номерами:') ;

    for i:=1 to n do

    if i mod 2=1 then write (a[i]:4) ;

    writeln;

    end.

    Пример:

    Массив A:

    13 77 63 94 75 87 22 56 59 42

    Четных чисел: 4

    Элементы с нечетными номерами:

    13 63 75 22 59
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Нужно составить программу в paskal ABC: Массив содержит n случайных двузначных чисел. Определить сколько в данном массиве четных чисел. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы