Задать вопрос
28 мая, 09:15

Напишите программу для Pascal. Пользователь с клавиатуры вводит любое четырехзначное число необходимо определить равна ли сумма тысяч и десятков сумме сотен и единиц и вывести соответствующий ответ на экран Например: 3671 - нет 3641 - да

+1
Ответы (1)
  1. 28 мая, 11:10
    0
    Var a:integer;

    begin

    readln (a) ;

    if (a div 1000 + (a div 10) mod 10 = a mod 10 + (a div 100) mod 10) then writeln ('yes')

    else writeln ('no') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу для Pascal. Пользователь с клавиатуры вводит любое четырехзначное число необходимо определить равна ли сумма тысяч и ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы