Задать вопрос
3 декабря, 03:38

Из-за непогоды были отменены рейсы самолетов. Ненадолго проглянуло солнце: на N часов и M минут. Напишите программу, которая определяет, сколько самолетов успеет вылететь за это время, если на взлетной полосе может быть только один самолет, а интервал между взлетом двух самолетов - Z минут? Формат входных данных: С клавиатуры вводятся через пробел 3 числа: n, m, z, обозначающие часы и минуты, на которые проглянуло солнце и интервал между взлетом двух самолетов. Формат входных данных: На экран вывести количество успевших взлететь самолетов. Примеры входных и выходных данных: Ввод: Вывод: 1 12 33 2 1 15 25 3

+2
Ответы (1)
  1. 3 декабря, 05:01
    0
    Программа на языке pascal, успехов в учебе.

    program pr;

    var n, m, z, k, i, vm:integer;

    begin

    readln (n, m, z) ;

    vm:=n*60+m;

    i:=1;

    while i<=vm do

    begin

    k:=k+1;

    i:=i+z;

    end;

    writeln (k) ;

    readln;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Из-за непогоды были отменены рейсы самолетов. Ненадолго проглянуло солнце: на N часов и M минут. Напишите программу, которая определяет, ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы