Задать вопрос
12 ноября, 22:34

Задачи на массив в Turbo Pascal

1) Определите, на сколько отличается рост самого высокого и самого низкого учащегося в классе?

2) результаты переписи населения, которые хранятся в памяти компьютера. Элемент массива - год рождения жителя. Подсчитайте общее число жителей, родившихся раньше 1958 года.

3) С 8 до 20 часов температура воздуха измерялась ежечасно, и результаты измерения заносились в компьютер. Известно, что в течение этого времени температура понижалась. Напишите программу, определяющую, в котором часу была впервые отмечена отрицательная температура

+5
Ответы (1)
  1. 13 ноября, 00:49
    0
    Program gt;

    var n, i, max, min:integer;

    a:array[1 ... 100]of integer;

    begin

    read (n) ;

    {n-кол-во учащихся}

    for i:=1 to n do

    read (a[i]) ;

    max:=a[1];

    min:=a[1];

    for i:=1 to n do

    begin

    if (a[i]>max) then max:=a[i];

    if (a[i]
    end;

    writeln (max,' ', min,'-росты')

    max:=max-min;

    writeln (max) ;

    end.

    2)

    program gt;

    var n, i, a, k:integer;

    begin

    read (n) ;

    k:=0;

    for i:=1 to n do

    begin

    read (a) ;

    if (a<1958) then k:=k+1;

    end;

    writeln (k) ;

    end.

    3)

    program gt;

    var i, q, a, l:integer;

    begin

    for i:=8 to 20 do

    begin

    read (a) ;

    if (a<0) then begin

    q:=q+1;

    if (q=1) then l:=i;

    end;

    end;

    writeln (l) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Задачи на массив в Turbo Pascal 1) Определите, на сколько отличается рост самого высокого и самого низкого учащегося в классе? 2) ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы