Задать вопрос
2 апреля, 14:18

Помогите надо написать задачу на Паскале

В заданном массиве определите количество элементов, которые меньше заданного с клавиатуры числа

+2
Ответы (1)
  1. 2 апреля, 15:56
    0
    Const

    n=10;

    var

    i, m, k:integer;

    a:array[1 ... n] of integer;

    begin

    Randomize;

    Write ('Исходный массив: ') ;

    for i:=1 to n do begin a[i]:=Random (90) + 10; Write (a[i],' ') end;

    Writeln;

    Writeln ('Введите целое число: ') ; Read (m) ;

    k:=0;

    for i:=1 to n do

    if a[i]
    Writeln ('Количество чисел, меньших ', m,' равно ', k)

    end.

    Тестовое решение:

    Исходный массив: 42 89 49 25 96 87 94 93 41 28

    Введите целое число:

    50

    Количество чисел, меньших 50 равно 5
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Помогите надо написать задачу на Паскале В заданном массиве определите количество элементов, которые меньше заданного с клавиатуры числа ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы