Задать вопрос
25 ноября, 13:24

Задача AДоска

Задается N. Нужно вывести цвет каждой клетки доски N x N, если известно, что они покрашены в шахматном порядке и клетка (1, 1) - белая.

Формат входных данных

Первая строка входного файла содержит единственное целое N (1 < = N < = 10).

Формат выходных данных

Выведите N строк в каждой N символов соответствующий цвету этой ячейки: 'W' - если белая и 'B' - если черная.

+5
Ответы (1)
  1. 25 ноября, 15:19
    0
    Var

    n, i, j: integer;

    begin

    readln (n) ;

    for i : = 1 to n do

    begin

    for j : = 1 to n do

    if ((j + i) mod 2 = 0) then

    write ('W':2)

    else

    write ('B':2) ;

    writeln;

    end;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Задача AДоска Задается N. Нужно вывести цвет каждой клетки доски N x N, если известно, что они покрашены в шахматном порядке и клетка (1, ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы