Задать вопрос
11 ноября, 16:11

Написать программу для решения следующей задачи: вычислить сумму и количество положительных элементов последовательности.

+2
Ответы (1)
  1. 11 ноября, 16:44
    0
    Var

    sum, count, t : integer;

    begin

    sum : = 0; count : = 0;

    while not eoln do

    begin

    read (t) ;

    if t > 0 then

    begin

    sum : = sum + t;

    count : = count + 1;

    end;

    writeln (sum, ' ', count) ;

    end.

    если количество элементов указано

    var

    sum, count, t, n, i : integer;

    begin

    sum : = 0; count : = 0;

    read (n) ;

    for i : = 1 to n do

    begin

    read (t) ;

    if t > 0 then

    begin

    sum : = sum + t;

    count : = count + 1;

    end;

    writeln (sum, ' ', count) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу для решения следующей задачи: вычислить сумму и количество положительных элементов последовательности. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы