Задать вопрос
9 сентября, 12:17

Дано натуральное число найдите количество четных и нечетных цифр в нем. написать программу на паскале

+2
Ответы (1)
  1. 9 сентября, 15:46
    0
    Var

    A, c, n:integer;

    Begin

    WriteLn ('Введите натурально число') ;

    Read (A) ;

    c:=0;

    n:=0;

    While A>0 do

    Begin

    if (A mod 10) mod 2 = 0 then c:=c+1;

    if (A mod 10) mod 2 0 then n:=n+1;

    A:=A div 10;

    End;

    WriteLn ('Кол-во чётных цифр: ', c) ;

    WriteLn ('Кол-во нечётных цифр: ', n) ;

    End.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Дано натуральное число найдите количество четных и нечетных цифр в нем. написать программу на паскале ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы