Задать вопрос
12 июля, 11:58

На языке Паскаля

вводятся элементы найти сумму чисел которые делятся на 4 и оканчиваются на 4

+2
Ответы (1)
  1. 12 июля, 13:41
    0
    Var a:array[1 ... 100] of integer;

    i, k, sum, n:integer;

    begin

    writeln ('Введите количество элементов массива') ;

    read (n) ;

    k:=0;

    sum:=0;

    writeln ('Введите элементы массива') ;

    for i:=1 to n do begin

    read (a[i]) ;

    if (a[i] mod 4 = 0) and (a[i] mod 10 = 4) then begin

    k:=k+1;

    sum:=sum+a[i];

    end;

    end;

    writeln ('Количество элементов = ', k,' Сумма элементов = ', sum) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «На языке Паскаля вводятся элементы найти сумму чисел которые делятся на 4 и оканчиваются на 4 ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Похожие вопросы по информатике
1. (x делится без остатка на 2 и на 3) записать на языке паскаля. 2. (х не делится на 5) записать на языке паскаля. 3. (величина х не кратна 3) записать на языке паскаля.
Ответы (1)
1) C клавиатуры вводятся 10 чисел. Найти сумму тех из них, которые больше 10. 2) Найти произведение двузначных нечетных чисел. 3) С клавиатуры вводятся N чисел.
Ответы (1)
Из ряда натуральных чисел от 1 до 1500 вычеркнули все числа, которые делятся на 2, затем все числа, которые делятся на 3, затем все числа, которые делятся на 5, а затем все числа, которые делятся на 7. Сколько чисел осталось?
Ответы (1)
Из ряда натуральных чисел от 1 до 2000 вычеркнули все числа, которые делятся на 2, затем все числа, которые делятся на 3, затем все числа, которые делятся на 5, а затем все числа, которые делятся на 7. Сколько чисел осталось?
Ответы (1)
Помогите решить задачи! 1. Дан массив размера 10, числовые значения которого вводятся с клавиатуры. Вывести максимальный элемент данного массива и его номер. 2. Дан массив размера 10, числовые значения которого вводятся с клавиатуры.
Ответы (1)