Задать вопрос
17 сентября, 18:51

1. Написать программу, вычисляющую сумму отрицательных чисел, кратных 5, среди пяти, вводимых с клавиатуры.

2. Написать программу, вычисляющую произведение чисел, оканчивающихся цифрами 2 и 4, среди пяти, вводимых с клавиатуры.

3. Написать программу, вычисляющую среднее арифметическое чисел, принадлежащих диапазону [-5; 5], среди пяти, вводимых с клавиатуры

+2
Ответы (1)
  1. 17 сентября, 21:10
    0
    Program z1;

    var a, i, sum:integer;

    Begin

    sum:=0;

    for i:=1 to 5 do

    begin;

    read (a) ;

    if (a<0) and (a mod 5=0) then

    sum:=sum+a;

    end;

    writeln (sum) ;

    End.

    Program z2;

    var a, p, i:integer;

    Begin

    p:=1;

    for i: = 1 to 5 do

    begin;

    read (a) ;

    if (a mod 10=2) or (a mod 10=4) then

    p:=p*a;

    end;

    writeln (p) ;

    End.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «1. Написать программу, вычисляющую сумму отрицательных чисел, кратных 5, среди пяти, вводимых с клавиатуры. 2. Написать программу, ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы