Задать вопрос
7 сентября, 05:44

1. Даны два ненулевых числа а и b. Напишите программу для нахождения суммы, разности, произведения и частного.

2. Напишите программу для нахождение периметра и площади прямоугольного треугольника, если даны длины его катетов а и b.

3. Ввести трехзначное число a. Напишите программу которая поменяет крайние цифры числа местами.

+2
Ответы (1)
  1. 7 сентября, 09:10
    0
    1)

    Program n1;

    var a, b: real;

    begin

    readln (a, b) ;

    writeln ('разность: ', a-b) ;

    writeln ('произведение: ', a*b) ;

    writeln ('сумма: ', a+b) ;

    writeln ('частное: ', a/b) ;

    end.

    2)

    Program n2;

    var a, b, c: real;

    begin

    readln (a, b) ;

    c:=sqrt (a*a+b*b) ;

    writeln ('площадь: ',0.5*a*b) ;

    writeln ('периметр: ', a+b+c) ;

    end.

    3)

    Program n3;

    var d1, d2, d3, a: integer;

    begin

    write ('введите число: ') ;

    readln (a) ;

    d1: = a div 100;

    d2:=a div 10 mod 10;

    d3:=a mod 10;

    writeln (d3, d2, d1) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «1. Даны два ненулевых числа а и b. Напишите программу для нахождения суммы, разности, произведения и частного. 2. Напишите программу для ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы