Задать вопрос
14 декабря, 22:15

Составить программу, которая в зависимости от порядкового номера месяца выводит на экран количество дней в этом месяце. Рассмотреть два случая: 1. год високосный.

2. год не является високосным

+3
Ответы (1)
  1. 14 декабря, 22:51
    0
    Program G;

    Uses Crt;

    Var count, num, ch: integer;

    Begin

    ClrScr;

    Writeln ('Год високосный? 1 - да, 0 - нет') ;

    Readln (Ch) ;

    If ch=1 then

    Begin

    Writeln ('Введите номер месяца') ;

    Readln (num) ;

    Сase num of

    1, 3, 5, 7, 8, 10, 12: writeln ('В месяце 31 день.') ;

    4, 6, 9, 11: writeln ('В месяце 30 дней.') ;

    2: writeln ('В месяце 29 дней') ;

    else writeln ('Некорректный ввод данных')

    End;

    End

    Else if ch=0 then

    Begin

    Writeln ('Введите номер месяца') ;

    Readln (num) ;

    Сase num of

    1, 3, 5, 7, 8, 10, 12: writeln ('В месяце 31 день.') ;

    4, 6, 9, 11: writeln ('В месяце 30 дней.') ;

    2: writeln ('В месяце 28 дней') ;

    else writeln ('Некорректный ввод данных')

    End;

    End

    Else writeln ('Некорректный ввод данных') ;

    Readln;

    End.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составить программу, которая в зависимости от порядкового номера месяца выводит на экран количество дней в этом месяце. Рассмотреть два ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы