Задать вопрос
9 марта, 18:18

Алгоритм евклида для вычисления нод двух натуральных чисел формируется так нужно заменять большее число на разность большего и меньшего до тех пор пока одно из них не станет равно нулю тогда второе и есть нод напишите программу которая реализует этот алгоритм какой цикл тут нужно использовать

+5
Ответы (1)
  1. 9 марта, 18:43
    0
    Var

    a, b:integer;

    begin

    Write ('Введите два натуральных числа ') ; Readln (a, b) ;

    while ab do

    if a > b then a : = a - b

    else b : = b - a;

    Writeln ('НОД=', a)

    end.

    Тестовое решение:

    Введите два натуральных числа 28 16

    НОД=4
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Алгоритм евклида для вычисления нод двух натуральных чисел формируется так нужно заменять большее число на разность большего и меньшего до ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы